Thursday, September 15, 2016

Spanning-Tree Protocol [STP] Artikel 12 Februari 2012 Ditulis Ulang 15 September 2016

Spanning Tree Protokol merupakan protokol jaringan komputer yang bekerja pada sebuah peralatan jaringan komputer yang bernama switch. Protokol ini memiliki fungsi untuk mendeteksi dan menangani redudancy pada sebuah jalur di jaringan komputer yang menggunakan switch. Redudancy ini dapat terjadi  secara sengaja ataupun tidak sengaja, seperti yang saya jelaskan dalam perkuliahan Manajemen LAN hari rabu tanggal 14 September 2016 kemarin.
Redundancy ini akan membentuk sebuah looping antar peralatan jaringan komputer melalui media transmisi terutama kabel UTP. Hal yang paling terlihat saat proses perancangan jaringan komputer menggunakan paket tracer terhadap kejadian redundancy ini dapat dilihat pada gambar diatas pada bagian yang dilingkari. Untuk mempelajari proses STP menangani reduncy ini maka kerjakan contoh konfigurasi berikut ini.
Alamat IP  Komputer
  1. PC 1 : 192.168.1.3 255.255.255.0
  2. PC 2 : 192.168.1.2 255.255.255.0 
Konfigurasi VLANKonfigurasi VTP dengan mengacu table berikut ini
Switch Name 
VTP Operating Mode 
VTP Domain 
S1
Server
TFSTTA
S2
Client
TFSTTA
S3
Client
TFSTTA
 

Dengan perintah sebagai berikut : 
1. switch 1 :  
  • S1(config)#vtp mode server  
  • S1(config)#vtp domain TFSTTA
2.   switch 2 :    
  • S2(config)#vtp mode client 
  • S2(config)#vtp domain TFSTTA
3. switch 3 :
  • S3(config)#vtp mode client 
  • S3(config)#vtp domain TFSTTA
Konfigurasi Trunk dan Native VLAN 
1. switch 1 : 
  • S1(config)#interface range fa0/1-4 
  • S1(config-if-range)#switchport mode trunk 
  • S1(config-if-range)#switchport trunk native vlan 99 
  • S1(config-if-range)#no shutdown 
  • S1(config-if-range)#end 
2. switch 2
  • S2(config)# interface range fa0/1-4 
  • S2(config-if-range)#switchport mode trunk  
  • S2(config-if-range)#switchport trunk native vlan 99 
  •  S2(config-if-range)#no shutdown 
  • S2(config-if-range)#end
3. switch 3 :
  • S3(config)# interface range fa0/1-4 
  • S3(config-if-range)#switchport mode trunk 
  • S3(config-if-range)#switchport trunk native vlan 99
  • S3(config-if-range)#no shutdown 
  • S3(config-if-range)#end
Kemudian konfigurasikan VLAN di switch 1 atau switch yang menggunakan mode server dengan mengacu pada tabel berikut 
 
VLAN
  VLAN Name
VLAN 99 
Admin
VLAN 10 
Fakultas
VLAN 20 
Mahasiswa
VLAN 30
Tamu
  • S1(config)#vlan 99 
  • S1(config-vlan)#name Admin 
  • S1(config-vlan)#exit 
  • S1(config)#vlan 10 
  • S1(config-vlan)#name Fakultas
  • S1(config-vlan)#exit
  • S1(config)#vlan 20   
  • S1(config-vlan)#name Mahasiswa
  • S1(config-vlan)#exit
  • S1(config)#vlan 30 
  • S1(config-vlan)#name Tamu 
  • S1(config-vlan)#exit 
     
Setelah semua dikerjakan ketikkan perintah show vlan brief pada setiap switch dan pastikan semua VLAN telah muncul pada setiap switch.

Konfigurasi interface ke VLAN
1. switch 1 :
  • S1(config)#interface vlan99
  • S1(config-if)#ip address 192.168.99.11 255.255.255.0
  • S1(config-if)#no shutdown
2. switch 2 :
  • S2(config)#interface vlan99
  • S2(config-if)#ip address 192.168.99.12 255.255.255.0
  • S2(config-if)#no shutdown 
3. switch 3 :
  • S3(config)#interface vlan99         
  • S3(config-if)#ip address 192.168.99.13 255.255.255.0
  • S3(config-if)#no shutdown 

Mengkonfigurasi ethernet switch yang portnya terhubung ke PC ke dalam VLAN [jangan lupa ethernet yang digunakan diposisikan eneble] dalam hal ini fa0/3 pada switch 1 dan switch 3 agar port tersebut dibuat switchport mode access  dan switchport access vlan 30 
Konfigurasi STP di switch 1[sebelumnya ketikan perintah #show spanning-tree vlan] untuk memastikan spanning tree protocol belum aktif, cara mengaktifkannya melalui switch mode server atau switch 1 ketikan perintah berikut ini, dan akan ada perubahan pada rancangan paket tracer tersebut.
Di  Switch 1:
  • S1(config)#spanning-tree vlan 1 priority 4096 
  • S1(config)#spanning-tree vlan 10 priority 4096
  • S1(config)#spanning-tree vlan 20 priority 4096
  • S1(config)#spanning-tree vlan 30 priority 4096 
  • S1(config)#exit 

14 comments:

  1. sangat membantu

    kunjungi juga gan

    http://jaketkuning.unsri.ac.id/rafi/blog/1079/

    ReplyDelete
  2. makasih gan sangat membantu
    kunjungi jg blog saya gan
    http://jaketkuning.unsri.ac.id/Rianyolanra/blog/1073/

    ReplyDelete
  3. Blog ini sangat membantu saya.
    kunjungi juga blog saya.
    http://jaketkuning.unsri.ac.id/ShandyFerial/blog/1083/

    ReplyDelete
  4. numpang share gan
    http://jaketkuning.unsri.ac.id/dika58/blog/1104/

    ReplyDelete
  5. permisi,ikutan belajar tentang STP
    http://jaketkuning.unsri.ac.id/Sigit/blog/1105/

    ReplyDelete
  6. numpang belajar gan
    mampir juga ke http://jaketkuning.unsri.ac.id/alihanafiah/blog/1090/

    ReplyDelete
  7. misi, tolong komen tulisan saya :D
    http://jaketkuning.unsri.ac.id/ardhani/blog/1107/

    thanks :D

    ReplyDelete
  8. misi gan
    tlng komen ya blog saya
    http://jaketkuning.unsri.ac.id/harialgenovrafajri/blog/1093/

    ReplyDelete
  9. terima kasih atas artikelnya, mari belajar bersama :)
    http://jaketkuning.unsri.ac.id/hardiyanti/blog/1098/

    ReplyDelete
  10. makasih gan artikelnya membantu..
    mampir jg ya http://jaketkuning.unsri.ac.id/ahmed/blog/1110/

    ReplyDelete
  11. makasih artikelnya, mampir jga yaa http://jaketkuning.unsri.ac.id/sukardono/blog/1122/

    ReplyDelete
  12. wah nice info ni, silakan mampir ke blog ana ya
    http://jaketkuning.unsri.ac.id/21051992/blog/1129/

    ReplyDelete
  13. Rombongan Unsri, terima kasih kunjungannya, tunggu kunjungan saya di blog anda

    ReplyDelete
  14. sangat membantu gan
    kunjungi juga gan
    http://jaketkuning.unsri.ac.id/rafi/blog/1357/

    ReplyDelete

Note: Only a member of this blog may post a comment.